Issue with Newly Created Tournament Visibility
Incident Report for Betconstruct Status
Resolved
This incident has been resolved.
Posted Nov 19, 2024 - 20:08 GMT+04:00
Investigating
We are currently investigating this issue.
Posted Nov 18, 2024 - 16:40 GMT+04:00
This incident affected: CMS and Casino Tournaments.