Issue with Jira

Incident Report for Betconstruct Status

Resolved

This incident has been resolved.
Posted Apr 16, 2026 - 11:13 GMT+04:00

Investigating

Hello,
Kindly be informed that currently we can not see and manage the Jira tickets.
We apologize for any inconvenience this may cause.
Posted Apr 16, 2026 - 10:14 GMT+04:00
This incident affected: Jira.