Issue with Newly Created Tournament Visibility
Incident Report for Betconstruct Status
Resolved
This incident has been resolved.
Posted Nov 15, 2024 - 23:45 GMT+04:00
Investigating
We are currently investigating this issue.
Posted Nov 15, 2024 - 12:37 GMT+04:00
This incident affected: Casino Tournaments.