Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Sep 07, 2025 - 14:00 GMT+04:00
Scheduled
Microgaming Category: All Services
Detail: As part of our continuous efforts to enhance our products and services, please be informed that system maintenance will be carried out during the period mentioned below. This maintenance is intended to improve the stability and reliability of our services.
Sunday, 7 September 2025 • 18:00 - 19:00 (GMT+8) • 10:00 - 11:00 (GMT+0) All Services (Including slots games and Microgaming Live games)
We appreciate your patience and understanding during this time. Should you have any questions, please do not hesitate to contact your Account Manager or our support team directly.
Impact: All games, APIs and BackOffice will be temporarily unavailable.
Platform: MG+ Single Wallet (Seamless Wallet)
Date and Time (GMT+8): Sunday, 7 September 2025 18:00 - 19:00 (GMT+8) Sunday, 7 September 2025, 10:00 - 11:00 (GMT+0)
Posted Sep 05, 2025 - 10:20 GMT+04:00
This scheduled maintenance affected: 3rd Party Provider.