Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Jul 08, 2025 - 06:00 GMT+04:00
Scheduled
We continuously strive to deliver an excellent product to our partners. Thus, server update plays a great role to satisfy the needs. With that being said, we'd like to provide you with more details about the planned maintenance Playson will be performing.
Maintenance Schedule:
Date: Tuesday 8th of July 2025 Time**:** 4 AM CET time Risk Classification: Low Expected Downtime: 5-10 minutes Purpose: Deploying updates to the server. Please note: During the maintenance, you may experience transaction failures. We kindly request you to keep the scheduled maintenance in mind when dealing with possible customer queries.
Please note that this maintenance and upgrade require no action from your end. Games will become available again once the server is restarted. This notice is for informational purposes only.
If you experience any issues inconsistent with this notice or you'd like to clarify it in more detail, do not hesitate to contact us for immediate assistance on support@playson.com
Posted Jul 07, 2025 - 11:21 GMT+04:00
This scheduled maintenance affected: 3rd Party Provider.