Relax Gaming Provider Planned Maintenance
Scheduled for Oct 2, 11:00 - 13:00 GMT+04:00
Update
We will be undergoing scheduled maintenance during this time.
Posted Sep 10, 2024 - 12:31 GMT+04:00
Scheduled
Date and Time: 02/10/2024 11:00-13:00 (GMT+4)
Expected Impact: All the connected services will be unavailable
Posted Sep 10, 2024 - 12:31 GMT+04:00
This scheduled maintenance affects: 3rd Party Provider.